Uploading Flash Game to this Site (Invisible Bug)

2 posts (showing 1-2)
swcommander

Market Level 0Community Level 0
6 posts

Hello. I am seeing a weird bug when I upload a game to this site    (i.e.  flashgamedistribution.com)

First, I should say that I uploaded my first game (Red Thief) without any problems. It was a 640 by 480 Flash game made with Flashpunk in Flash Develop. Recently, I have tried to upload 2 more games (they are all about 20MB but these last 2 are 800 by 600). All 3 games use the same wrapper and low level code.

For my 2 most recent games, the problem I get is that no visual is shown and it says "Flash Preview (0 by 0)" instead of the game graphics. However, sound is being played. The game runs just fine on every single other web site I have uploaded it to (Kong, Newgrounds,...). The problem only happens with FGL.

Here is what I have tried with similar results:

1) adding/removing the FGL ads code (Manual Ad API)  ... makes no difference. I am using the same code I did before with Red Thief. I re-uploaded that game it and it works but my newer games don't. I even re-compiled and re-built Red Thief. Uploaded it and it works. However, the 2 new ones don't

2) removing the Preloader... makes no difference.

3) Uploading the newer games as 640 by 480 ... makes no difference.

 

Has anyone else experienced this weird problem? Again, it only happens with this site... no problems on any other sites. I assume that there is some code in my game that conflicts with this particular site... but no way to know what it could be.

Thank you,

 Alex

posted 2017-01-17T17:07:31-08:00 | edited 2017-01-17T17:10:11-08:00
swcommander

Market Level 0Community Level 0
6 posts

I figured out why it was happening. It seems like I had embedded too much graphics. After removing 2 big backrounds, it brought me to below 20 MB, which then made it work. Still, was not aware that there was a limit on this site.

posted 2017-01-17T19:22:22-08:00