Enhance Error (resolved)

19 posts (showing 1-19)
Lobotomy

Market Level 0Community Level 2
20 posts

Every time when I try to enhance my games  I get this message :  

Error

Session is not complete!

Enhance™ My App

Uh oh! Something went wrong!

Our engineering team have been notified and we'll get in touch when we have fixed the problem!

 

 

Am I doing something wrong or currently there are some issues?

posted 2016-11-03T04:46:19-07:00 | edited 2016-11-03T04:47:31-07:00
FGL_Dave

FGL AdminCommunity Level 4
284 posts

Hey Lobotomy,

Thanks for reporting this issue. We're looking into this on our end and should have an update for you soon!

posted 2016-11-03T11:50:36-07:00
okra

Market Level 0Community Level 0
4 posts

I get this error too. Built a game with Adobe Air using Starling

posted 2016-11-04T14:49:03-07:00
Zebestov

Market Level 0Community Level 0
9 posts

I have same trouble.

posted 2016-11-05T00:55:16-07:00
Zebestov

Market Level 0Community Level 0
9 posts

Fixed. Thanks!

posted 2016-11-05T14:48:04-07:00
FGL_Dave

FGL AdminCommunity Level 4
284 posts

Yup, this issue is now resolved!

posted 2016-11-06T12:57:34-08:00
nekonomicon

Market Level 0Community Level 0
1 posts

I have same trouble now.

posted 2016-12-30T13:42:05-08:00
FGL_Dave

FGL AdminCommunity Level 4
284 posts

Posted on 30th Dec '16 by nekonomicon

I have same trouble now.

Hi nekonomicon,

Is your app "Against the Stream"? I can see some failed builds in our build logs for that app, due to some resources in the APK that are causing an issue with rebuilding the app during the Enhancement process. We're on the case and should have a fix for it pretty soon - though as it is the holiday season this may be somewhat delayed. I'll post back here when it has been fixed and let you know.

Thanks!

posted 2016-12-30T15:08:12-08:00
Roningrad

Market Level 0Community Level 0
3 posts

"Against the Stream" is mine. Thanks for your answer.

posted 2016-12-31T12:40:16-08:00 | edited 2017-01-12T08:36:32-08:00
Penry

Market Level 3Community Level 5
517 posts

I'm seeing the same error today as i try to enhance.

posted 2017-01-14T08:10:54-08:00
FGL_Dave

FGL AdminCommunity Level 4
284 posts

Posted on 14th Jan '17 by Penry

I'm seeing the same error today as i try to enhance.

Hi Penry,

I can see a recent failure on the app "Shrink or Score", which I guess is yours. I've had a look at the build log and I can see that there has been a resource error when enhancing your app. I've notified an engineer who should be able to fix this, and I will get back to you when the issue is reported as resolved so you can try again.

If you want to have a go at fixing the issue from your end, the exact issue is that there is no @string/app_name text resource defined - it might be possible to make sure this is defined in whatever IDE you are using to build your app. However, if you'd rather wait for a fix on our end that is also fine - we should be able to fix it, as we have ran into similar issues in the past with certain apps and we can usually fix them fairly quickly.

Thanks!

posted 2017-01-14T08:42:54-08:00
Penry

Market Level 3Community Level 5
517 posts

Thanks for the quick reply FGL Dave, This game was created using an older verision of OpenFL/Haxe. I've googled @string/app_name, and it's pointing towards an entry in the application.xml (or i guess a missing entry in this case). I can look as working around it if it's something that should be there ...

 

posted 2017-01-15T11:31:05-08:00
Penry

Market Level 3Community Level 5
517 posts

Hi Dave, I've spent a couple of hours trying to figure out what would be needed to fix it my end - " there is no @string/app_name text resource defined " - and i'm no wiser, It can't be resolved by an entry in the application.xml, or the androidmanifest.xml, which is a pain to override in openfl anyway !  If Enhance requires specific things setting up in OpenFL / Haxe, likes setting up this string, any pointers towards what it needs would be greatly appreciated, as i can't find any doc to explain what' s needed !

posted 2017-01-16T07:17:45-08:00
Roningrad

Market Level 0Community Level 0
3 posts

I build simple games with Kivy (Python) for Android. It's the first time your service has enchanced my apps very well. But since late December I have seen this error.

Do I need to wait until your engineer will solve the problem? Or maybe did I something wrong?

P.S. The app I'm having problems with is called "Against the Stream".

posted 2017-01-16T12:58:52-08:00
FGL_Dave

FGL AdminCommunity Level 4
284 posts

Hey guys,

We've found a way we can fix this issue from our end, and the root cause. Some of the newer SDKs we have added to Enhance aren't very happy if that particular resource entry does not exist - however we have engineers working actively on the issue and it should hopefully be solved very soon (the plan is to check if this entry exists, and if it doesn't have the Enhance process create it for you).

Unfortunately, I don't have the direct experience with OpenFL to be able to help with this. However, I've been advised that this issue should be fixed relatively quickly - probably this week.

I'll post back here when it is solved; for now, sit tight!

posted 2017-01-17T04:49:09-08:00
FGL_Dave

FGL AdminCommunity Level 4
284 posts

Good news, the fix for this was deployed a bit earlier than anticipated. Could you all give it another try and let me know if you are continuing to see the issue?

Thanks!

posted 2017-01-17T07:50:51-08:00
Penry

Market Level 3Community Level 5
517 posts

Thanks for the quick fix - the issue with Shrink or Score enhancing has gone, and it's completing ok :) - can hopefully test the spk this week !, tnx again

posted 2017-01-17T12:25:04-08:00
Roningrad

Market Level 0Community Level 0
3 posts

There are no issues anymore. Thank you very much for your work!

posted 2017-01-17T12:33:35-08:00
FGL_Dave

FGL AdminCommunity Level 4
284 posts

Glad to hear it!

posted 2017-01-17T14:32:22-08:00